LYP.CN

LNMP安装wordpress 3.8.1出现502 bad gateway的解决办法

近日在一台linode的vps上搭建了LNMP,打算放一个个人学习股票投资心得的小网站(基于wordpress),从WordPress官网下载了最新版的代码(3.8.1),安装到第二步的时候却卡壳了,总是出现502 Bad Gateway错误。以前遇到这种问题都是因为负载过大而php-fpm的参数设置不当导致的,因为这次是个全新的网站,没任何人知道,所以首先排除负载方面的原因,网上很多关于解决502错误的方案的文章,大多数都是那几套老掉牙的办法,事实上现在每次搭建lnmp平台,那些参数都会事先得到修改优化,因此问题肯定是出在了某个还没被发现的角落。因为wordpress安装的时候会自动生成config文件,而这次安装到了这一步总是过不去,没能生成配置文件,于是索性先手工创建了wordpress的config文件,安装居然顺利完成。

登录wordpress后台,各项设置都很顺利,然后就想换个模板,打开结果该死的502错误又来了。。。在网上查了很多资料,貌似只有少数人遇到这个问题,而他们给出的方案是降低wordpress版本(比如到2.8版)重新安装。这不科学啊,一定是有哪个小地方出现了偏差,于是把降级这个方案先放一边,从系统日志查起吧。。

看了一下系统日志,发现了这么一段:

Feb 10 11:20:37 li671-57 kernel: php-cgi[16760]: segfault at 8048 ip 00007f9ed95f4e9c sp 00007fff4 c3b3540 error 4 in libsqlite3.so.0.8.6[7f9ed95d8000+8c000]

问题会不会出在这里呢?

google了一下,发现有人也看到了这样的错误,他的临时解决方法是将libsqlite3.so.0.8.6先更名(参考这里)。于是试着做了一下

mv /usr/lib64/libsqlite3.so.0.8.6 /usr/lib64/libsqlite3.so.0.8.6.bak

问题果然解决了!

当然,俺没时间研究这个问题的真实原因了,就留给有心人去探个究竟吧,嘿嘿。。

(5689次阅读)

已有 4 条评论 腾讯微博
  1. 麻匪x

    果然有用,点赞。

    2016年1月12日 21:35 回复
  2. 小凡

    问题解决,真是一针见血的解答

    2014年7月24日 15:27 回复
  3. hhb

    it works +1

    2014年7月10日 22:44 回复
  4. Geek柴

    thx,it works

    2014年3月16日 23:18来自新浪微博 回复